36 thoughts on “Setup SSL for WordPress on Google Cloud (Click-to-Deploy) (Latest)

  1. Check out this tutorial with each command listed individually with images:

    https://www.onepagezen.com/free-ssl-certificates-wordpress-google-cloud-click-to-deploy/

  2. Got this problem on running "$sudo certbot –apache
    ", anyone have experience with this?

    The apache plugin is not working; there may be problems with your existing configuration.

    The error was: NoInstallationError('Cannot find Apache executable apache2ctl')

  3. I searched YouTube, Google for a long time……finally got such a video that really works. Thanks…..I needed it very much

  4. thank you very much!, I spent one week trying to solve this problem until a found your video, works perfectly

  5. Hi. I had first configured certbot for my domain without www. It works fine. But now that I add www to the domain inside WordPress for redirects, there is mismatch, because my certificate was generated for the URL without www. How to fix this?

  6. Still works perfectly in June 2020, a great tutorial thank you. I decided not to enforce automatic redirection via the command-line whilst following, as WordPress is already configured to do that. I'm also using CloudFlare, but I'm going to assume now this CertBot + Let's Encrypt (cert.) have been installed it will encrypt the data between CloudFlare and the server which is another layer of protection for website visitors instead of just a "vanity" SSL cert. showing at the front-end so to speak when using only CloudFlare. Now if I turn the proxy off my website visitors will still be safe in the meantime.

  7. thanks man! do you know if this works with Google Cloud's Snapshot? I think I tried with your old tutorial before, but was getting errors when I try to create instance from snapshots of instances that implemented SSL installation. Thanks!

  8. you just type : sudo /opt/bitnami/bnhelper-tool ,and select let's Encrypt then following the instruction .It is easier and faster.

  9. /opt/bitnami/apache2/scripts/ctl.sh : httpd could not be started and I open my site:Apache2 Debian Default Page

  10. err message
    ● apache2.service – The Apache HTTP Server

    Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)

    Active: failed (Result: exit-code) since Wed 2020-05-20 16:37:14 UTC; 48ms ago

    Process: 6101 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILURE)

  11. i am getting "your connection is not fully secure" but if I am login in wp panal say you are secure

  12. I got ssl certificate but now when I'm logging in wordpress admin panel.
    It's not opening and telling "Your connection is not secure."
    Also showing- "the owner has configured their website improperly to protect your information from being stolen ,Firefox has not connected to their website."

    Please tell me what should I do now

  13. Terrible Results, wordpress seem to be not accessible after following these steps, i tried also to remove Lets encrypt, it took hours but also failed. now im only left with one option rebuild the entire thing.

  14. I'm getting an error:
    Detail: DNS problem: NXDOMAIN looking up A for wwww.mywebsite.com
    – check that a DNS record exists for this domain

Leave a Reply

Your email address will not be published. Required fields are marked *